E语言简单的Post案例

简单的AI小案例
1.gif

首先添加精益模块
Snipaste_2019-08-29_21-42-12.png

然后代码如下:

.版本 2
.支持库 iext
.支持库 EThread

.程序集 窗口程序集_启动窗口

.子程序 _编辑框1_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.判断开始 (键代码 = #回车键)
    _按钮1_被单击 ()
.默认

.判断结束



.子程序 Post请求函数
.局部变量 POST地址, 文本型
.局部变量 POST数据, 文本型
.局部变量 网页返回, 文本型
.局部变量 转换后文本, 文本型

'网上随便找的接口
POST地址 = “http://api.qingyunke.com/api.php?key=free&appid=0&msg=” + #引号 + 编辑框1.内容 + #引号
网页返回 = 到文本 (网页_访问S (POST地址, 1, POST数据))
转换后文本 = 编码_Utf8到Ansi (到字节集 (网页返回))


透明标签1.标题 = 取文本中间 (转换后文本, 24, 取文本长度 (转换后文本) - 25)


' POST数据 = “aaa”

.子程序 _按钮1_被单击


启动线程 (&Post请求函数, , )
透明标签1.标题 = “Loading ……”

©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页